[FRsAG] deb.sury.org... miroir ou sauvegarde ?

Wallace wallace at morkitu.org
Mar 4 Aou 13:41:02 CEST 2020


Je confirme que du php plus vieux que 5.6 sous Debian > 8 c'est la
misère et pour moi impossible tellement les libs ssl et d'autres
dépendances ont évoluées, ils n'arrivent plus à se brancher ensemble
(correction de bug et sécu qui empêche le fonctionnement).

Seule solution réinstaller une vieille Debian qui a la bonne version
mais y aura d'autres soucis comme les ciphers tls / ssh obsolètes, toute
la suite supervision, métrologie, sauvegarde moderne qui ne pourra pas
se brancher dessus...


Le 21/07/2020 à 17:38, Pierre DOLIDON a écrit :
> Le 21/07/2020 à 17:33, Arnaud Launay a écrit :
>> Le Mon, Jul 20, 2020 at 04:26:51PM +0200, Stéphane Rivière a écrit:
>>> Merci à Ronan pour le partage...
>>> Je laisse ça à dispo ici, pour un bout de temps, si ça peut aider
>>> d'autre paléojessiens à avoir du PHP 7.4 dessus (entre autres).
>>> https://stef.genesix.org/pub/sury-jessie
>> J'en ai une rigolote dans l'autre sens: j'ai un client qui a besoin de
>> php *4* pour une appli avant sa migration d'ici la fin de l'année en
>> théorie. Je ne suis même pas sûr de pouvoir retrouver une etch pour lui
>> faire tourner ça dessus... Je pars du principe que ça n'existe pas sous
>> buster, on est d'accord ? :)
>>
>>     Arnaud.
>> _______________________________________________
>> Liste de diffusion du FRsAG
>> http://www.frsag.org/
>
>
> à l'époque, j'avais écrit une procédure pour le compiler sur debian 7
> (doit être adaptable en debian 8, sur stretch et buster, j'en sais
> rien, j'ai jamais essayé, mais ça doit être la misère avec les libs)
>
> ## installer OpenSSL 0.9.X :
> ./config --prefix=/opt/applis/openssl-0.9.8zh
>
> ## installer les dépendances (Debian 7)
> aptitude install flex libssl-dev libcurl4-openssl-dev
> libgnutls-openssl27 libcurl-dev libcurl4 libxml2-dev libpng-dev
> libpng3-dev libmcrypt-dev mcrypt libtomcrypt-dev libjpeg8-dev
> libfreetype6-dev libmhash-dev libmysqlclient-dev libexpat1-dev
> libxslt1-dev libgd2-xpm-dev autoconf bison libbison-dev libbz2-dev
> libbz2-dev curl libxpm-dev libicu-dev unixodbc-dev libreadline-dev
> libgmp-dev libjpeg-dev libpspell-dev libicu-dev
>
> ## faire un peu de karaté avec les libs
> mkdir /usr/kerberos
> mkdir /usr/include/freetype2/freetype/
> ln -s /usr/lib/x86_64-linux-gnu/libjpeg.so /usr/lib/libjpeg.so
> ln -s /usr/lib/x86_64-linux-gnu/libpng.so /usr/lib/libpng.so
> ln -s /usr/lib/x86_64-linux-gnu/libmysqlclient.so
> /usr/lib/libmysqlclient.so
> ln -s /usr/lib/x86_64-linux-gnu/libmysqlclient.so.18
> /usr/lib/libmysqlclient.so.18
> ln -s /usr/lib/x86_64-linux-gnu/libexpat.so /usr/lib/libexpat.so
> ln -s /usr/include/freetype2/freetype.h
> "/usr/include/freetype2/freetype/freetype.h"
> ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib64
>
> ## configurer le bouzin
> ./configure --prefix=/opt/applis/php-4.4.9 --with-zlib-dir
> --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr
> --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib
> --with-gd --disable-rpath --enable-inline-optimization --with-zlib
> --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl
> --enable-mbregex --with-mhash --enable-zip --with-pcre-regex
> --with-mysql=/usr --with-mysql-sock=/var/run/mysqld/mysqld.sock
> --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf
> --with-openssl=/opt/applis/openssl-0.9.8zh
> --with-openssl-dir=/opt/applis/openssl-0.9.8zh
> --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-imap-ssl
> --with-kerberos --with-gettext --with-expat-dir=/usr --enable-fastcgi
>
>
> et voilà ça marchait.
>
> _______________________________________________
> Liste de diffusion du FRsAG
> http://www.frsag.org/


Plus d'informations sur la liste de diffusion FRsAG