[FRsAG] Annonce - LTS pour debian 6

Xavier Beaudouin kiwi at oav.net
Ven 18 Avr 09:44:39 CEST 2014


Hello,

Je dis pas grand chose, mais je vais placer ma pierre a l'édifice.

>> Pourquoi ne pas simplement prolonger la période oldstable?
>> Si la securityteam n'est plus sur Squeeze il devient important de migrer.
> 
> Parce qu'il faut des gens pour le faire. Et une communauté basé entièrement sur du bénévolat n'a pas nécessairement que ça à faire...

+1 de plus si tu veux qu'il y du support a long terme et que ta boite utilise debian pour gagner de l'argent, il est peut-être intéressant de contribuer au projet debian. C'est ça l'opensource. Ca peux pas toujours se passer dans un sens : les gens bénévoles travaillent gratuitement pour ta boite. (Car c'est ça en fait qu'il se passe).

>> De notre côté tout est déjà organisé, on s'est laissé un an pour migrer
>> les 6 vers 7, il reste que quelques serveurs à gérer en attente de
>> retour client.
>> Squeeze a bien vécu, si on commence à ralonger les durées de vie, autant
>> reporter les prochains freeze.
> 
> C'est un choix, ceci dit cela impose de migrer au même rythme que Debian, c'est à dire tous les deux ans, ce qui peut être soutenu pour certaines personnes. En comparaison, certains laissent des systèmes OpenBSD tourner pendant des années sans problème. Côté Linux, certaines distributions ont un support à long-terme de plusieurs années également pour les gens qui veulent avant tout de la stabilité.
> 
> Dans tous les cas c'est un compromis et ça ne se règle pas en cinq minutes...

Je trouve que migrer tous les 2 ans n'est pas super soutenu. Car en deux ans, les technos bougent, les outils bougent, et dans l'informatique ne pas s'adapter c'est mourir.

Oui effectivement si tu attends le dernier moment la tu en chie, car le code développé en PHP ne marche plus (bon bah c'est aussi la rançon de la gloire d'utiliser php, mais c'est un autre débat), les softs ont des bugs corrigé que tu as pu exploiter pour t'aider, les fichiers de conf partent du fichier plat a un délire a coup de ldapsearch/ldapadd.... bref le changement fais mal.

Si par contre tu travailles proactivement avec les gens qui dev les outils, avec une plateforme de test, alors tu as l'habitude de changer rapidement de releases, tu as des choses qui utilisent les bonnes technos stabilisées, etc...

Pour info, j'ai repris l'admin d'une boite ou ils ne voulaient JAMAIS upgrader quoi que ce soit... Résultat :

- Un système d'info troué (mais pas avec heartbleed),
- Des ubuntu 7.04 qui étaient en production,
- Des bugs à la con avec les nouveaux OS (type mon Windows s'identifie pas avec l'AD... normal y a un patch, upgrade),
- A chaque mise à jour on a des travaux énormes de tests qui peuvent durer plusieurs mois alors qui s'ils avaient suivit un peu les mises à jours on aurais moins de taf,
- De l'instabilité latente dûes aux problèmes de cpu récents avec des OS pas prévu pour 8 coeurs ou plus,
- ...

Donc si tu veux pas trop mettre à jour, tu peux garder des openbsd (mais ca c'est un risque, vu les derniers commits dans le repo de openbsd, a toi de voir), ou rester sur des OS proprio tels que Solaris, ou les mise à jour major release = reinstall complete...

Tu as de la chance avec Debian que les mises à jours sont faciles. Vas essayer CentOS ou RHEL, passer de RHEL 5 à 6 n'est pas super facile alors que debian ou ubuntu... c'est piece of cake.


Arrêtez de ronchonner car des volontaires ont décidés qu'il faut arrêter de garder des vieilleries, c'est pour le bien de tous, et vous pouvez toujours forker debian et faire votre propre distribution et gérer vous même les patches de secu...

Xavier
-------------- section suivante --------------
Une pièce jointe autre que texte a été nettoyée...
Nom: signature.asc
Type: application/pgp-signature
Taille: 163 octets
Desc: Message signed with OpenPGP using GPGMail
URL: <http://www.frsag.org/pipermail/frsag/attachments/20140418/2bf8d00b/attachment.sig>


Plus d'informations sur la liste de diffusion FRsAG