[FRsAG] pppd + PAM (w/LDAP) => perte de patience

Valentin Surrel valentin at surrel.org
Mer 27 Nov 16:01:14 CET 2013


Bonjour la liste,

Je m'arrache les cheveux sur un petit problème depuis plusieurs jours et
je craque. Je viens donc demander si un oeil neuf pourrait avoir une idée.

Contexte : tunnel IPSec/l2tp ; je veux authentifier la session PPP par
LDAP (et sans déployer Yet Another Brique comme un radius par exemple).

pppd et capable de causer à PAM et je l'ai configuré de la sorte, j'ai
mis un petit "ppp" dans pam.d. Et ça marche presque. Voici le log qui
m'intrigue tant :

Nov 27 15:48:16 srv02 pppd[26438]: pppd 2.4.5 started by root, uid 0
Nov 27 15:48:16 srv02 pppd[26438]: using channel 89
Nov 27 15:48:16 srv02 pppd[26438]: Using interface ppp0
Nov 27 15:48:16 srv02 pppd[26438]: Connect: ppp0 <--> /dev/pts/5
Nov 27 15:48:16 srv02 pppd[26438]: sent [LCP ConfReq id=0x1 <mru 1100>
<asyncmap 0x0> <auth pap> <magic 0xfbfddb9e> <pcomp> <accomp>]
Nov 27 15:48:16 srv02 pppd[26438]: rcvd [LCP ConfReq id=0x1 <mru 1400>
<asyncmap 0x0> <magic 0xac191e2b> <pcomp> <accomp>]
Nov 27 15:48:16 srv02 pppd[26438]: sent [LCP ConfAck id=0x1 <mru 1400>
<asyncmap 0x0> <magic 0xac191e2b> <pcomp> <accomp>]
Nov 27 15:48:16 srv02 pppd[26438]: rcvd [LCP ConfAck id=0x1 <mru 1100>
<asyncmap 0x0> <auth pap> <magic 0xfbfddb9e> <pcomp> <accomp>]
Nov 27 15:48:16 srv02 pppd[26438]: sent [LCP EchoReq id=0x0
magic=0xfbfddb9e]
Nov 27 15:48:16 srv02 pppd[26438]: rcvd [PAP AuthReq id=0x1
user="vsurrel" password=<hidden>]
Nov 27 15:48:16 srv02 pppd[26438]: Initializing PAM (3) for user vsurrel
Nov 27 15:48:16 srv02 pppd[26438]: ---> PAM INIT Result = 0
Nov 27 15:48:16 srv02 pppd[26438]: Attempting PAM authentication
Nov 27 15:48:16 srv02 pppd[26438]: PAM Authentication OK for vsurrel
Nov 27 15:48:16 srv02 pppd[26438]: Attempting PAM account checks
Nov 27 15:48:16 srv02 pppd[26438]: PAM Account OK for vsurrel
Nov 27 15:48:16 srv02 pppd[26438]: PAM Session opened for user vsurrel
Nov 27 15:48:16 srv02 pppd[26438]: user vsurrel logged in on tty pts/5
intf ppp0
Nov 27 15:48:16 srv02 pppd[26438]: PAP peer authentication failed for
vsurrel
Nov 27 15:48:16 srv02 pppd[26438]: Connection terminated.
Nov 27 15:48:16 srv02 pppd[26438]: Exit.


On voit donc clairement
- PAM Authentication OK for vsurrel
- PAM Account OK for vsurrel
- PAM Session opened for user vsurrel

MAIS suivi à la même seconde par un
- PAP peer authentication failed for vsurrel

que je n'arrive absolument pas à expliquer. Auriez-vous une petite piste ?

A vot' bon coeur !

Valentin


For the sake of completeness :

/etc/pam.d/ppp
auth       required	pam_ldap.so config=/etc/pam_ldap.conf
account  required      pam_ldap.so
password required        pam_ldap.so
session  required     pam_ldap.so

/etc/ppp/pap-secrets
# Pas de ckeck ; c'est PAM qui authentifie
*        ppp   *      *

/etc/ppp/xl2tpd.options
auth
login
nodefaultroute
mtu 1100
mru 1100
lock
proxyarp
require-pap
name ppp
ms-dns 192.168.200.10
debug


-------------- section suivante --------------
Une pièce jointe autre que texte a été nettoyée...
Nom: signature.asc
Type: application/pgp-signature
Taille: 555 octets
Desc: OpenPGP digital signature
URL: <http://www.frsag.org/pipermail/frsag/attachments/20131127/ce097f03/attachment.pgp>


More information about the FRsAG mailing list